Issue sending emails

Incident Report for Acaboom

Resolved

We experienced connection issues with our transactional email service that affected our ability to send emails. The intermittent issue lasted for about 50 minutes. The provider’s engineering team has deployed a fix, and services are now back to normal. Apologies for any inconvenience during this time.
Posted Jun 26, 2025 - 02:30 BST