Sold property information and images

Incident Report for Acaboom

Resolved

The good news is the site is now up and running again. We apologise for any inconvenience caused while the service was unavailable.
Posted Oct 09, 2025 - 14:23 BST

Investigating

The Land Registry is currently experiencing technical issues (an “Service Unavailable” error), which means their server is temporarily down or is overloaded. As a result, this is affecting our access to sold comparables and any associated images (where applicable).

We’re in contact with the Land Registry to confirm when the service will be restored. We apologise for any inconvenience caused in the meantime.
Posted Oct 09, 2025 - 13:40 BST
This incident affected: Website and Mobile app.